Code

store::network: Add a store writer plugin sending objects over the network.
[sysdb.git] / src / Makefile.am
index d979672d7dc388d85c6214f66849d30462f79398..7cff3e8a5b5dafc05568cc41c6ab8f435de6a46d 100644 (file)
@@ -87,6 +87,7 @@ libsysdb_la_SOURCES = \
                frontend/parser.c include/frontend/parser.h \
                frontend/sock.c include/frontend/sock.h \
                frontend/session.c \
+               frontend/store.c \
                frontend/query.c \
                utils/avltree.c include/utils/avltree.h \
                utils/channel.c include/utils/channel.h \
@@ -152,6 +153,7 @@ pkgbackendcollectdlibdir = $(pkgbackendlibdir)/collectd
 pkgbackendpuppetlibdir = $(pkgbackendlibdir)/puppet
 pkgcnamelibdir = $(pkglibdir)/cname
 pkgtimeserieslibdir = $(pkglibdir)/timeseries
+pkgstorelibdir = $(pkglibdir)/store
 
 pkglib_LTLIBRARIES =
 pkgbackendlib_LTLIBRARIES =
@@ -159,6 +161,7 @@ pkgbackendcollectdlib_LTLIBRARIES =
 pkgbackendpuppetlib_LTLIBRARIES =
 pkgcnamelib_LTLIBRARIES =
 pkgtimeserieslib_LTLIBRARIES =
+pkgstorelib_LTLIBRARIES =
 
 if BUILD_PLUGIN_CNAMEDNS
 pkgcnamelib_LTLIBRARIES += plugins/cname/dns.la
@@ -217,6 +220,14 @@ sysdbd_LDADD += -dlopen plugins/timeseries/rrdtool.la
 sysdbd_DEPENDENCIES += plugins/timeseries/rrdtool.la
 endif
 
+if BUILD_PLUGIN_STORENETWORK
+pkgstorelib_LTLIBRARIES += plugins/store/network.la
+plugins_store_network_la_SOURCES = plugins/store/network.c
+plugins_store_network_la_LDFLAGS = $(AM_LDFLAGS) libsysdbclient.la -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/store/network.la
+sysdbd_DEPENDENCIES += plugins/store/network.la
+endif
+
 include/client/sysdb.h: include/client/sysdb.h.in ../version
        source ../version; sed \
            -e "s/@SDB_VERSION_MAJOR@/$$VERSION_MAJOR/g" \