Code

store::network: Add a store writer plugin sending objects over the network.
[sysdb.git] / src / Makefile.am
index c7c53e3289189d9fbb7a67ba4cd7151b18ba1758..7cff3e8a5b5dafc05568cc41c6ab8f435de6a46d 100644 (file)
@@ -2,6 +2,7 @@ SUBDIRS = liboconfig
 
 # coverage related flags are only set when gcov is enabled
 AM_CFLAGS = @STRICT_CFLAGS@ @COVERAGE_CFLAGS@ @PROFILING_CFLAGS@
+AM_CXXFLAGS = @STRICT_CXXFLAGS@ @COVERAGE_CFLAGS@ @PROFILING_CFLAGS@
 AM_LDFLAGS = @COVERAGE_LDFLAGS@ @PROFILING_LDFLAGS@
 AM_CPPFLAGS  = -I"${top_srcdir}/src/include"
 AM_CPPFLAGS += -DSYSCONFDIR='"${sysconfdir}"'
@@ -49,6 +50,8 @@ pkgclientinclude_HEADERS = \
 noinst_LTLIBRARIES = libsysdbclient.la libsysdb.la
 
 libsysdbclient_la_SOURCES = \
+               core/data.c include/core/data.h \
+               core/time.c include/core/time.h \
                client/client.c include/client/sysdb.h \
                client/sock.c include/client/sock.h \
                utils/error.c include/utils/error.h \
@@ -56,7 +59,8 @@ libsysdbclient_la_SOURCES = \
                utils/strbuf.c include/utils/strbuf.h
 libsysdbclient_la_CFLAGS = $(AM_CFLAGS)
 libsysdbclient_la_CPPFLAGS = $(AM_CPPFLAGS) $(LTDLINCL)
-libsysdbclient_la_LDFLAGS = $(AM_LDFLAGS) -version-info 0:0:0 -pthread
+libsysdbclient_la_LDFLAGS = $(AM_LDFLAGS) -version-info 0:0:0 \
+               -pthread -lm -lrt
 libsysdbclient_la_LIBADD = $(LIBLTDL)
 
 # don't use strict CFLAGS for flex code
@@ -72,14 +76,18 @@ libsysdb_la_SOURCES = \
                core/store.c include/core/store.h \
                core/store-private.h \
                core/store_expr.c \
+               core/store_json.c \
                core/store_lookup.c \
                core/data.c include/core/data.h \
-               include/core/timeseries.h \
+               core/time.c include/core/time.h \
+               core/timeseries.c include/core/timeseries.h \
+               frontend/analyzer.c \
                frontend/connection.c include/frontend/connection.h \
                frontend/connection-private.h \
                frontend/parser.c include/frontend/parser.h \
                frontend/sock.c include/frontend/sock.h \
                frontend/session.c \
+               frontend/store.c \
                frontend/query.c \
                utils/avltree.c include/utils/avltree.h \
                utils/channel.c include/utils/channel.h \
@@ -88,13 +96,13 @@ libsysdb_la_SOURCES = \
                utils/os.c include/utils/os.h \
                utils/proto.c include/utils/proto.h \
                utils/strbuf.c include/utils/strbuf.h \
-               core/time.c include/core/time.h \
                utils/unixsock.c include/utils/unixsock.h
 libsysdb_la_CFLAGS = $(AM_CFLAGS)
 libsysdb_la_CPPFLAGS = $(AM_CPPFLAGS) $(LTDLINCL)
-libsysdb_la_LDFLAGS = $(AM_LDFLAGS) -version-info 0:0:0 -pthread -lm
+libsysdb_la_LDFLAGS = $(AM_LDFLAGS) -version-info 0:0:0 \
+               -pthread -lm -lrt
 libsysdb_la_LIBADD = libsysdb_fe_parser.la \
-               $(LIBLTDL) -lrt liboconfig/liboconfig.la
+               $(LIBLTDL) liboconfig/liboconfig.la
 libsysdb_la_DEPENDENCIES = libsysdb_fe_parser.la liboconfig/liboconfig.la
 
 if BUILD_WITH_LIBDBI
@@ -116,10 +124,11 @@ sysdb_SOURCES = tools/sysdb/main.c include/client/sysdb.h \
                tools/sysdb/command.c tools/sysdb/command.h \
                tools/sysdb/input.c tools/sysdb/input.h \
                core/object.c include/core/object.h \
-               utils/llist.c include/utils/llist.h
+               utils/llist.c include/utils/llist.h \
+               utils/os.c include/utils/os.h
 sysdb_CFLAGS = -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\"" \
                $(AM_CFLAGS) @READLINE_CFLAGS@
-sysdb_LDADD = libsysdb_scanner.la libsysdbclient.la @READLINE_LIBS@
+sysdb_LDADD = libsysdb_scanner.la libsysdbclient.la @READLINE_LIBS@ -lm
 endif
 
 sysdbd_SOURCES = tools/sysdbd/main.c include/sysdb.h \
@@ -143,12 +152,16 @@ pkgbackendlibdir = $(pkglibdir)/backend
 pkgbackendcollectdlibdir = $(pkgbackendlibdir)/collectd
 pkgbackendpuppetlibdir = $(pkgbackendlibdir)/puppet
 pkgcnamelibdir = $(pkglibdir)/cname
+pkgtimeserieslibdir = $(pkglibdir)/timeseries
+pkgstorelibdir = $(pkglibdir)/store
 
 pkglib_LTLIBRARIES =
 pkgbackendlib_LTLIBRARIES =
 pkgbackendcollectdlib_LTLIBRARIES =
 pkgbackendpuppetlib_LTLIBRARIES =
 pkgcnamelib_LTLIBRARIES =
+pkgtimeserieslib_LTLIBRARIES =
+pkgstorelib_LTLIBRARIES =
 
 if BUILD_PLUGIN_CNAMEDNS
 pkgcnamelib_LTLIBRARIES += plugins/cname/dns.la
@@ -158,28 +171,36 @@ sysdbd_LDADD += -dlopen plugins/cname/dns.la
 sysdbd_DEPENDENCIES += plugins/cname/dns.la
 endif
 
-if BUILD_PLUGIN_COLLECTD
-pkgbackendcollectdlib_LTLIBRARIES += backend/collectd/unixsock.la
-backend_collectd_unixsock_la_SOURCES = backend/collectd/unixsock.c
-backend_collectd_unixsock_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
-sysdbd_LDADD += -dlopen backend/collectd/unixsock.la
-sysdbd_DEPENDENCIES += backend/collectd/unixsock.la
+if BUILD_PLUGIN_COLLECTDUNIXSOCK
+pkgbackendcollectdlib_LTLIBRARIES += plugins/backend/collectd/unixsock.la
+plugins_backend_collectd_unixsock_la_SOURCES = plugins/backend/collectd/unixsock.c
+plugins_backend_collectd_unixsock_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/backend/collectd/unixsock.la
+sysdbd_DEPENDENCIES += plugins/backend/collectd/unixsock.la
+endif
+
+if BUILD_PLUGIN_FACTER
+pkgbackendlib_LTLIBRARIES += plugins/backend/facter.la
+plugins_backend_facter_la_SOURCES = plugins/backend/facter.cc
+plugins_backend_facter_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version -lfacter
+sysdbd_LDADD += -dlopen plugins/backend/facter.la
+sysdbd_DEPENDENCIES += plugins/backend/facter.la
 endif
 
 if BUILD_PLUGIN_MKLIVESTATUS
-pkgbackendlib_LTLIBRARIES += backend/mk-livestatus.la
-backend_mk_livestatus_la_SOURCES = backend/mk-livestatus.c
-backend_mk_livestatus_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
-sysdbd_LDADD += -dlopen backend/mk-livestatus.la
-sysdbd_DEPENDENCIES += backend/mk-livestatus.la
+pkgbackendlib_LTLIBRARIES += plugins/backend/mk-livestatus.la
+plugins_backend_mk_livestatus_la_SOURCES = plugins/backend/mk-livestatus.c
+plugins_backend_mk_livestatus_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/backend/mk-livestatus.la
+sysdbd_DEPENDENCIES += plugins/backend/mk-livestatus.la
 endif
 
 if BUILD_PLUGIN_PUPPETSTORECONFIGS
-pkgbackendpuppetlib_LTLIBRARIES += backend/puppet/store-configs.la
-backend_puppet_store_configs_la_SOURCES = backend/puppet/store-configs.c
-backend_puppet_store_configs_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
-sysdbd_LDADD += -dlopen backend/puppet/store-configs.la
-sysdbd_DEPENDENCIES += backend/puppet/store-configs.la
+pkgbackendpuppetlib_LTLIBRARIES += plugins/backend/puppet/store-configs.la
+plugins_backend_puppet_store_configs_la_SOURCES = plugins/backend/puppet/store-configs.c
+plugins_backend_puppet_store_configs_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/backend/puppet/store-configs.la
+sysdbd_DEPENDENCIES += plugins/backend/puppet/store-configs.la
 endif
 
 if BUILD_PLUGIN_SYSLOG
@@ -190,6 +211,23 @@ sysdbd_LDADD += -dlopen plugins/syslog.la
 sysdbd_DEPENDENCIES += plugins/syslog.la
 endif
 
+if BUILD_PLUGIN_TIMESERIESRRDTOOL
+pkgtimeserieslib_LTLIBRARIES += plugins/timeseries/rrdtool.la
+plugins_timeseries_rrdtool_la_SOURCES = plugins/timeseries/rrdtool.c
+plugins_timeseries_rrdtool_la_CFLAGS = $(AM_CFLAGS) @RRD_CFLAGS@
+plugins_timeseries_rrdtool_la_LDFLAGS = $(AM_LDFLAGS) @RRD_LIBS@ -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/timeseries/rrdtool.la
+sysdbd_DEPENDENCIES += plugins/timeseries/rrdtool.la
+endif
+
+if BUILD_PLUGIN_STORENETWORK
+pkgstorelib_LTLIBRARIES += plugins/store/network.la
+plugins_store_network_la_SOURCES = plugins/store/network.c
+plugins_store_network_la_LDFLAGS = $(AM_LDFLAGS) libsysdbclient.la -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/store/network.la
+sysdbd_DEPENDENCIES += plugins/store/network.la
+endif
+
 include/client/sysdb.h: include/client/sysdb.h.in ../version
        source ../version; sed \
            -e "s/@SDB_VERSION_MAJOR@/$$VERSION_MAJOR/g" \