Code

store: Added a generic JSON formatter.
[sysdb.git] / src / Makefile.am
index ef6367ea75910948cf3fcd3642c2f71f16b0b856..64b6ec46c41a4639879357c846e3089f21d6f269 100644 (file)
@@ -72,9 +72,11 @@ libsysdb_la_SOURCES = \
                core/store.c include/core/store.h \
                core/store-private.h \
                core/store_expr.c \
+               core/store_json.c \
                core/store_lookup.c \
                core/data.c include/core/data.h \
                core/timeseries.c include/core/timeseries.h \
+               frontend/analyzer.c \
                frontend/connection.c include/frontend/connection.h \
                frontend/connection-private.h \
                frontend/parser.c include/frontend/parser.h \
@@ -160,7 +162,7 @@ sysdbd_LDADD += -dlopen plugins/cname/dns.la
 sysdbd_DEPENDENCIES += plugins/cname/dns.la
 endif
 
-if BUILD_PLUGIN_COLLECTD
+if BUILD_PLUGIN_COLLECTDUNIXSOCK
 pkgbackendcollectdlib_LTLIBRARIES += plugins/backend/collectd/unixsock.la
 plugins_backend_collectd_unixsock_la_SOURCES = plugins/backend/collectd/unixsock.c
 plugins_backend_collectd_unixsock_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
@@ -184,15 +186,6 @@ sysdbd_LDADD += -dlopen plugins/backend/puppet/store-configs.la
 sysdbd_DEPENDENCIES += plugins/backend/puppet/store-configs.la
 endif
 
-if BUILD_PLUGIN_RRDTOOL
-pkgtimeserieslib_LTLIBRARIES += plugins/timeseries/rrdtool.la
-plugins_timeseries_rrdtool_la_SOURCES = plugins/timeseries/rrdtool.c
-plugins_timeseries_rrdtool_la_CFLAGS = $(AM_CFLAGS) @RRD_CFLAGS@
-plugins_timeseries_rrdtool_la_LDFLAGS = $(AM_LDFLAGS) @RRD_LIBS@ -module -avoid-version
-sysdbd_LDADD += -dlopen plugins/timeseries/rrdtool.la
-sysdbd_DEPENDENCIES += plugins/timeseries/rrdtool.la
-endif
-
 if BUILD_PLUGIN_SYSLOG
 pkglib_LTLIBRARIES += plugins/syslog.la
 plugins_syslog_la_SOURCE = plugins/syslog.c
@@ -201,6 +194,15 @@ sysdbd_LDADD += -dlopen plugins/syslog.la
 sysdbd_DEPENDENCIES += plugins/syslog.la
 endif
 
+if BUILD_PLUGIN_TIMESERIESRRDTOOL
+pkgtimeserieslib_LTLIBRARIES += plugins/timeseries/rrdtool.la
+plugins_timeseries_rrdtool_la_SOURCES = plugins/timeseries/rrdtool.c
+plugins_timeseries_rrdtool_la_CFLAGS = $(AM_CFLAGS) @RRD_CFLAGS@
+plugins_timeseries_rrdtool_la_LDFLAGS = $(AM_LDFLAGS) @RRD_LIBS@ -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/timeseries/rrdtool.la
+sysdbd_DEPENDENCIES += plugins/timeseries/rrdtool.la
+endif
+
 include/client/sysdb.h: include/client/sysdb.h.in ../version
        source ../version; sed \
            -e "s/@SDB_VERSION_MAJOR@/$$VERSION_MAJOR/g" \