Code

store: Added a generic JSON formatter.
[sysdb.git] / src / Makefile.am
index c7c53e3289189d9fbb7a67ba4cd7151b18ba1758..64b6ec46c41a4639879357c846e3089f21d6f269 100644 (file)
@@ -72,9 +72,11 @@ libsysdb_la_SOURCES = \
                core/store.c include/core/store.h \
                core/store-private.h \
                core/store_expr.c \
+               core/store_json.c \
                core/store_lookup.c \
                core/data.c include/core/data.h \
-               include/core/timeseries.h \
+               core/timeseries.c include/core/timeseries.h \
+               frontend/analyzer.c \
                frontend/connection.c include/frontend/connection.h \
                frontend/connection-private.h \
                frontend/parser.c include/frontend/parser.h \
@@ -143,12 +145,14 @@ pkgbackendlibdir = $(pkglibdir)/backend
 pkgbackendcollectdlibdir = $(pkgbackendlibdir)/collectd
 pkgbackendpuppetlibdir = $(pkgbackendlibdir)/puppet
 pkgcnamelibdir = $(pkglibdir)/cname
+pkgtimeserieslibdir = $(pkglibdir)/timeseries
 
 pkglib_LTLIBRARIES =
 pkgbackendlib_LTLIBRARIES =
 pkgbackendcollectdlib_LTLIBRARIES =
 pkgbackendpuppetlib_LTLIBRARIES =
 pkgcnamelib_LTLIBRARIES =
+pkgtimeserieslib_LTLIBRARIES =
 
 if BUILD_PLUGIN_CNAMEDNS
 pkgcnamelib_LTLIBRARIES += plugins/cname/dns.la
@@ -158,28 +162,28 @@ sysdbd_LDADD += -dlopen plugins/cname/dns.la
 sysdbd_DEPENDENCIES += plugins/cname/dns.la
 endif
 
-if BUILD_PLUGIN_COLLECTD
-pkgbackendcollectdlib_LTLIBRARIES += backend/collectd/unixsock.la
-backend_collectd_unixsock_la_SOURCES = backend/collectd/unixsock.c
-backend_collectd_unixsock_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
-sysdbd_LDADD += -dlopen backend/collectd/unixsock.la
-sysdbd_DEPENDENCIES += backend/collectd/unixsock.la
+if BUILD_PLUGIN_COLLECTDUNIXSOCK
+pkgbackendcollectdlib_LTLIBRARIES += plugins/backend/collectd/unixsock.la
+plugins_backend_collectd_unixsock_la_SOURCES = plugins/backend/collectd/unixsock.c
+plugins_backend_collectd_unixsock_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/backend/collectd/unixsock.la
+sysdbd_DEPENDENCIES += plugins/backend/collectd/unixsock.la
 endif
 
 if BUILD_PLUGIN_MKLIVESTATUS
-pkgbackendlib_LTLIBRARIES += backend/mk-livestatus.la
-backend_mk_livestatus_la_SOURCES = backend/mk-livestatus.c
-backend_mk_livestatus_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
-sysdbd_LDADD += -dlopen backend/mk-livestatus.la
-sysdbd_DEPENDENCIES += backend/mk-livestatus.la
+pkgbackendlib_LTLIBRARIES += plugins/backend/mk-livestatus.la
+plugins_backend_mk_livestatus_la_SOURCES = plugins/backend/mk-livestatus.c
+plugins_backend_mk_livestatus_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/backend/mk-livestatus.la
+sysdbd_DEPENDENCIES += plugins/backend/mk-livestatus.la
 endif
 
 if BUILD_PLUGIN_PUPPETSTORECONFIGS
-pkgbackendpuppetlib_LTLIBRARIES += backend/puppet/store-configs.la
-backend_puppet_store_configs_la_SOURCES = backend/puppet/store-configs.c
-backend_puppet_store_configs_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
-sysdbd_LDADD += -dlopen backend/puppet/store-configs.la
-sysdbd_DEPENDENCIES += backend/puppet/store-configs.la
+pkgbackendpuppetlib_LTLIBRARIES += plugins/backend/puppet/store-configs.la
+plugins_backend_puppet_store_configs_la_SOURCES = plugins/backend/puppet/store-configs.c
+plugins_backend_puppet_store_configs_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/backend/puppet/store-configs.la
+sysdbd_DEPENDENCIES += plugins/backend/puppet/store-configs.la
 endif
 
 if BUILD_PLUGIN_SYSLOG
@@ -190,6 +194,15 @@ sysdbd_LDADD += -dlopen plugins/syslog.la
 sysdbd_DEPENDENCIES += plugins/syslog.la
 endif
 
+if BUILD_PLUGIN_TIMESERIESRRDTOOL
+pkgtimeserieslib_LTLIBRARIES += plugins/timeseries/rrdtool.la
+plugins_timeseries_rrdtool_la_SOURCES = plugins/timeseries/rrdtool.c
+plugins_timeseries_rrdtool_la_CFLAGS = $(AM_CFLAGS) @RRD_CFLAGS@
+plugins_timeseries_rrdtool_la_LDFLAGS = $(AM_LDFLAGS) @RRD_LIBS@ -module -avoid-version
+sysdbd_LDADD += -dlopen plugins/timeseries/rrdtool.la
+sysdbd_DEPENDENCIES += plugins/timeseries/rrdtool.la
+endif
+
 include/client/sysdb.h: include/client/sysdb.h.in ../version
        source ../version; sed \
            -e "s/@SDB_VERSION_MAJOR@/$$VERSION_MAJOR/g" \