Code

frontend: Drop sdb_fe_store_* in favor of sdb_store_query_execute.
[sysdb.git] / src / Makefile.am
index a7f6c9b73744c4f27dade47960386a7bea35a110..48561c344ac23664299cedb2a65a7b59688526eb 100644 (file)
@@ -12,7 +12,7 @@ AM_CPPFLAGS += -DPKGLIBDIR='"${pkglibdir}"'
 AM_YFLAGS = -d
 
 BUILT_SOURCES = include/client/sysdb.h include/sysdb.h \
-               frontend/grammar.h
+               frontend/grammar.h parser/grammar.h
 EXTRA_DIST = include/client/sysdb.h.in include/sysdb.h.in
 
 pkginclude_HEADERS = include/sysdb.h
@@ -68,7 +68,8 @@ libsysdbclient_la_LIBADD = $(LIBLTDL) @OPENSSL_LIBS@
 # don't use strict CFLAGS for flex code
 noinst_LTLIBRARIES += libsysdb_fe_parser.la
 libsysdb_fe_parser_la_SOURCES = \
-               frontend/grammar.y frontend/scanner.l
+               frontend/grammar.y frontend/scanner.l \
+               parser/grammar.y parser/scanner.l
 libsysdb_fe_parser_la_CFLAGS = @COVERAGE_CFLAGS@ @PROFILING_CFLAGS@ \
                -DBUILD_DATE="\"$$( date --utc '+%F %T' ) (UTC)\""
 libsysdb_la_SOURCES = \
@@ -77,9 +78,11 @@ libsysdb_la_SOURCES = \
                core/plugin.c include/core/plugin.h \
                core/store.c include/core/store.h \
                core/store-private.h \
+               core/store_exec.c \
                core/store_expr.c \
                core/store_json.c \
                core/store_lookup.c \
+               core/store_query.c \
                core/data.c include/core/data.h \
                core/time.c include/core/time.h \
                core/timeseries.c include/core/timeseries.h \
@@ -89,9 +92,10 @@ libsysdb_la_SOURCES = \
                frontend/parser.c include/frontend/parser.h \
                frontend/sock.c include/frontend/sock.h \
                frontend/session.c \
-               frontend/store.c \
                frontend/query.c \
+               parser/analyzer.c \
                parser/ast.c include/parser/ast.h \
+               parser/parser.c include/parser/parser.h \
                utils/avltree.c include/utils/avltree.h \
                utils/channel.c include/utils/channel.h \
                utils/error.c include/utils/error.h \