Code

frontend: Added module for generic connection handling.
[sysdb.git] / src / Makefile.am
index 3cdb58e906edbf36483dfb5c7beb81b05e6d7a30..24b41ae51bedb40ba510eccb7f0f75d1731ce792 100644 (file)
@@ -3,6 +3,7 @@ SUBDIRS = liboconfig
 AM_CFLAGS = @STRICT_CFLAGS@
 AM_CPPFLAGS  = -Iinclude
 AM_CPPFLAGS += -DSYSCONFDIR='"${sysconfdir}"'
+AM_CPPFLAGS += -DLOCALSTATEDIR='"${localstatedir}"'
 AM_CPPFLAGS += -DPKGLIBDIR='"${pkglibdir}"'
 
 BUILT_SOURCES = include/sysdb.h
@@ -25,6 +26,9 @@ libsysdb_la_SOURCES = \
                core/store.c include/core/store.h \
                include/core/data.h \
                core/error.c include/core/error.h \
+               frontend/connection.c include/frontend/connection.h \
+               frontend/sock.c include/frontend/sock.h \
+               utils/channel.c include/utils/channel.h \
                utils/llist.c include/utils/llist.h \
                utils/strbuf.c include/utils/strbuf.h \
                core/time.c include/core/time.h \