Code

doc/: Added local rules to hook HTML manpages into 'make (install-)html'.
[sysdb.git] / doc / Makefile.am
index a50754d924d969625d51812a9deb9eea40c064c9..e8c13ed4c472233dea41c7f8ce3dc9bddfb4a6f6 100644 (file)
@@ -74,7 +74,8 @@ html_DATA = \
 ADOC_FLAGS = \
                -f$(srcdir)/asciidoc.conf \
                -apackage_version=$(PACKAGE_VERSION) \
-               -alocalstatedir=$(localstatedir)
+               -alocalstatedir=$(localstatedir) \
+               $(ADOCFLAGS)
 # XXX: Make asciidoc use this stylesheet
 HTML_ATTRS = --stylesheet=$(srcdir)/sysdb-man.css
 
@@ -113,6 +114,9 @@ sysdbd-syslog.5.html: sysdbd-syslog.5.txt $(MAN_DEPS)
 sysdb.7.html: sysdb.7.txt sysdb-description.txt $(MAN_DEPS)
 sysdbql.7.html: sysdbql.7.txt sysdb-description.txt $(MAN_DEPS)
 
+html-local: $(html_DATA)
+install-html-local: install-htmlDATA
+
 .1.txt.1.xml:
        @ASCIIDOC@ $(ADOC_FLAGS) -b docbook -d manpage $<
 .5.txt.5.xml: