Code

Remove auto-generated doc from installed tmp directory.
[pkg-tig.git] / debian / rules
index b73bbd12f77021fd37ca74f3d9770594651afdda..e848beb0b16ddc05ce4d84fdf12ea1653da6c2d8 100755 (executable)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g -I/usr/include/ncursesw
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+CFLAGS   = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS  += -Wall -g -I/usr/include/ncursesw
+
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+
+LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -23,9 +30,12 @@ config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
-               CFLAGS="$(CFLAGS)"
+               CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -42,10 +52,11 @@ clean:
        $(MAKE) clean
        
        rm -f config.h config.log config.make config.status
-       rm -rf manual.html-chunked/
-       rm -f manual.pdf manual.html manual.toc
-       rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
-       rm -f NEWS.html README.html
+       rm -rf doc/manual.html-chunked/
+       rm -f doc/manual.pdf doc/manual.html doc/manual.toc
+       rm -f doc/tigmanual.7
+       rm -f doc/tig.1 doc/tig.1.html doc/tigrc.5 doc/tigrc.5.html
+       rm -f INSTALL.html NEWS.html README.html
        
        dh_clean 
 
@@ -56,9 +67,9 @@ install: build
        dh_installdirs
        
        $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
-       
-       # there is no need to ship this binary
-       rm debian/tig/usr/bin/test-graph
+       # don't ship install instructions; README only links to them
+       rm -f debian/tig/usr/share/doc/tig/INSTALL.html \
+               debian/tig/usr/share/doc/tig/README.html
        
        mkdir -p debian/tig/etc/bash_completion.d
        cp contrib/tig-completion.bash debian/tig/etc/bash_completion.d/tig
@@ -71,7 +82,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs NEWS
-       dh_installdocs BUGS TODO manual.pdf
+       dh_installdocs BUGS doc/manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip