Code

Remove auto-generated doc from installed tmp directory.
[pkg-tig.git] / debian / rules
index 962b55975a01ffb146d469af358be0e11175e598..e848beb0b16ddc05ce4d84fdf12ea1653da6c2d8 100755 (executable)
@@ -1,12 +1,24 @@
 #!/usr/bin/make -f
-# debian/ruls for tig
+# debian/rules for tig
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-CFLAGS = -Wall -g
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+CFLAGS   = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS  += -Wall -g -I/usr/include/ncursesw
+
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+
+LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -14,12 +26,21 @@ else
        CFLAGS += -O2
 endif
 
-build: build-stamp
+config.status: configure
+       dh_testdir
+       ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+               --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
+               CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+
+build: build-arch build-indep
 
-build-stamp:
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp: config.status
        dh_testdir
        
-       CFLAGS="$(CFLAGS)" $(MAKE) all doc
+       $(MAKE) all doc
        
        touch build-stamp
 
@@ -30,6 +51,13 @@ clean:
        
        $(MAKE) clean
        
+       rm -f config.h config.log config.make config.status
+       rm -rf doc/manual.html-chunked/
+       rm -f doc/manual.pdf doc/manual.html doc/manual.toc
+       rm -f doc/tigmanual.7
+       rm -f doc/tig.1 doc/tig.1.html doc/tigrc.5 doc/tigrc.5.html
+       rm -f INSTALL.html NEWS.html README.html
+       
        dh_clean 
 
 install: build
@@ -38,8 +66,10 @@ install: build
        dh_clean -k
        dh_installdirs
        
-       $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig \
-                       prefix=/usr mandir=/usr/share/man
+       $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
+       # don't ship install instructions; README only links to them
+       rm -f debian/tig/usr/share/doc/tig/INSTALL.html \
+               debian/tig/usr/share/doc/tig/README.html
        
        mkdir -p debian/tig/etc/bash_completion.d
        cp contrib/tig-completion.bash debian/tig/etc/bash_completion.d/tig
@@ -51,8 +81,8 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs
-       dh_installdocs BUGS TODO manual.pdf
+       dh_installchangelogs NEWS
+       dh_installdocs BUGS doc/manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip
@@ -65,5 +95,5 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install