Code

rules: Install 'NEWS' as upstream changelog, rather than as 'NEWS'.
[pkg-tig.git] / debian / rules
index 9666fa17a574fa9d7d61f43abc33a848cc0e5f53..b73bbd12f77021fd37ca74f3d9770594651afdda 100755 (executable)
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+CFLAGS = -Wall -g -I/usr/include/ncursesw
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -57,6 +57,9 @@ install: build
        
        $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
        
+       # there is no need to ship this binary
+       rm debian/tig/usr/bin/test-graph
+       
        mkdir -p debian/tig/etc/bash_completion.d
        cp contrib/tig-completion.bash debian/tig/etc/bash_completion.d/tig
        chmod 644 debian/tig/etc/bash_completion.d/tig
@@ -67,8 +70,8 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs
-       dh_installdocs NEWS BUGS TODO manual.pdf
+       dh_installchangelogs NEWS
+       dh_installdocs BUGS TODO manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip