Code

rules: Install 'NEWS' as upstream changelog, rather than as 'NEWS'.
[pkg-tig.git] / debian / rules
index 90e300ad78d52da4500c105904801f49ef5a628b..b73bbd12f77021fd37ca74f3d9770594651afdda 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for tig
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -23,7 +23,7 @@ config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
-               CFLAGS="$(CFLAGS)" LIBS="-lncursesw"
+               CFLAGS="$(CFLAGS)"
 
 build: build-stamp
 
@@ -45,6 +45,7 @@ clean:
        rm -rf manual.html-chunked/
        rm -f manual.pdf manual.html manual.toc
        rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
+       rm -f NEWS.html README.html
        
        dh_clean 
 
@@ -56,6 +57,9 @@ install: build
        
        $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
        
+       # there is no need to ship this binary
+       rm debian/tig/usr/bin/test-graph
+       
        mkdir -p debian/tig/etc/bash_completion.d
        cp contrib/tig-completion.bash debian/tig/etc/bash_completion.d/tig
        chmod 644 debian/tig/etc/bash_completion.d/tig
@@ -66,7 +70,7 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs
+       dh_installchangelogs NEWS
        dh_installdocs BUGS TODO manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
@@ -80,5 +84,5 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install