Code

patches: Added bts594549-pager-segfault.
[pkg-tig.git] / debian / rules
index 92ff9293e6e83db9f794134ea7219f4507e91bb8..969f53ddfe8384586bdf58efcdf2e3eab1e0fccd 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for tig
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -19,7 +19,9 @@ else
        CFLAGS += -O2
 endif
 
-config.status: configure
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
@@ -34,7 +36,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -45,6 +47,7 @@ clean:
        rm -rf manual.html-chunked/
        rm -f manual.pdf manual.html manual.toc
        rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
+       rm -f NEWS.html README.html
        
        dh_clean 
 
@@ -80,5 +83,5 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install