Code

patches: Removed asciidoc-8.4.dpatch.
[pkg-tig.git] / debian / rules
index f76af1df1704b7e17d1e78aa5b6a33d28cfe4994..9666fa17a574fa9d7d61f43abc33a848cc0e5f53 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
-# debian/ruls for tig
+# debian/rules for tig
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g -I/usr/include/ncursesw
+CFLAGS = -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -23,7 +23,7 @@ config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
-               CFLAGS="$(CFLAGS)" LIBS="-lncursesw"
+               CFLAGS="$(CFLAGS)"
 
 build: build-stamp
 
@@ -44,6 +44,8 @@ clean:
        rm -f config.h config.log config.make config.status
        rm -rf manual.html-chunked/
        rm -f manual.pdf manual.html manual.toc
+       rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
+       rm -f NEWS.html README.html
        
        dh_clean 
 
@@ -66,7 +68,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
-       dh_installdocs BUGS TODO manual.pdf
+       dh_installdocs NEWS BUGS TODO manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip
@@ -79,5 +81,5 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install