Code

Don't update CFLAGS if DEB_BUILD_OPTIONS contains noopt.
[pkg-tig.git] / debian / rules
index dafdc009c92d620bf9c21b406bb222b524810fe2..92ca06fe392bc5a565e16c3cd302ace7f4f0147c 100755 (executable)
@@ -20,12 +20,6 @@ CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
 
 LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
 config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \