Code

rules: (Again) pass -I/usr/include/ncursesw to CFLAGS.
[pkg-tig.git] / debian / rules
index f13c4e86d209f93ed9fe31de995d3474b97a9625..90ca50d6a79222f09427f0a58414c911d91bab76 100755 (executable)
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+CFLAGS = -Wall -g -I/usr/include/ncursesw
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -19,8 +19,6 @@ else
        CFLAGS += -O2
 endif
 
-include /usr/share/dpatch/dpatch.make
-
 config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
@@ -29,14 +27,14 @@ config.status: configure
 
 build: build-stamp
 
-build-stamp: config.status $(DPATCH_STAMPFN)
+build-stamp: config.status
        dh_testdir
        
        $(MAKE) all doc
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp