Code

rules: Split build target into build-{arch,indep} as recommended by policy.
[pkg-tig.git] / debian / rules
index 294dcdd4255394a5030f8effd1d16e04683522b8..63f259916940bf0497dadbac7e793adfc0bcb760 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for tig
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+CFLAGS = -Wall -g -I/usr/include/ncursesw
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -23,9 +23,12 @@ config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
-               CFLAGS="$(CFLAGS)" LIBS="-lncursesw"
+               CFLAGS="$(CFLAGS)"
 
-build: build-stamp
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -45,6 +48,7 @@ clean:
        rm -rf manual.html-chunked/
        rm -f manual.pdf manual.html manual.toc
        rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
+       rm -f NEWS.html README.html
        
        dh_clean 
 
@@ -66,8 +70,8 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs
-       dh_installdocs NEWS BUGS TODO manual.pdf
+       dh_installchangelogs NEWS
+       dh_installdocs BUGS manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip
@@ -80,5 +84,5 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install