Code

rules: Don't install contrib/tigrc as example any more.
[pkg-tig.git] / debian / rules
index 9666fa17a574fa9d7d61f43abc33a848cc0e5f53..5b4c2f5280eb3da0b1a497e9a1144e3126cd5873 100755 (executable)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+CFLAGS   = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS  += -Wall -g -I/usr/include/ncursesw
+
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+
+LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -23,9 +30,12 @@ config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
-               CFLAGS="$(CFLAGS)"
+               CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+
+build: build-arch build-indep
 
-build: build-stamp
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -42,10 +52,11 @@ clean:
        $(MAKE) clean
        
        rm -f config.h config.log config.make config.status
-       rm -rf manual.html-chunked/
-       rm -f manual.pdf manual.html manual.toc
-       rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
-       rm -f NEWS.html README.html
+       rm -rf doc/manual.html-chunked/
+       rm -f doc/manual.pdf doc/manual.html doc/manual.toc
+       rm -f doc/tigmanual.7
+       rm -f doc/tig.1 doc/tig.1.html doc/tigrc.5 doc/tigrc.5.html
+       rm -f INSTALL.html NEWS.html README.html
        
        dh_clean 
 
@@ -56,6 +67,9 @@ install: build
        dh_installdirs
        
        $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
+       # don't ship install instructions; README only links to them
+       rm -f debian/tig/usr/share/doc/tig/INSTALL.html \
+               debian/tig/usr/share/doc/tig/README.html
        
        mkdir -p debian/tig/etc/bash_completion.d
        cp contrib/tig-completion.bash debian/tig/etc/bash_completion.d/tig
@@ -67,9 +81,9 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs
-       dh_installdocs NEWS BUGS TODO manual.pdf
-       dh_installexamples contrib/tigrc
+       dh_installchangelogs NEWS.adoc
+       dh_installdocs doc/manual.pdf
+       dh_installexamples
        dh_link
        dh_strip
        dh_compress -X.pdf