Code

rules: Don't try to install TODO.
[pkg-tig.git] / debian / rules
index a2784d22642f1c1d3c3b9649cfe6be25ccdaf6d6..4128ddd1d6475f77d902105f0b8e3259f057cc24 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for tig
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+CFLAGS = -Wall -g -I/usr/include/ncursesw
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -19,8 +19,6 @@ else
        CFLAGS += -O2
 endif
 
-include /usr/share/dpatch/dpatch.make
-
 config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
@@ -29,14 +27,14 @@ config.status: configure
 
 build: build-stamp
 
-build-stamp: config.status $(DPATCH_STAMPFN)
+build-stamp: config.status
        dh_testdir
        
        $(MAKE) all doc
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -47,6 +45,7 @@ clean: unpatch
        rm -rf manual.html-chunked/
        rm -f manual.pdf manual.html manual.toc
        rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
+       rm -f NEWS.html README.html
        
        dh_clean 
 
@@ -68,8 +67,8 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs
-       dh_installdocs NEWS BUGS TODO manual.pdf
+       dh_installchangelogs NEWS
+       dh_installdocs BUGS manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip
@@ -82,5 +81,5 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install