Code

rules: Use NEWS.adoc in place of NEWS and remove BUGS
[pkg-tig.git] / debian / rules
index 969f53ddfe8384586bdf58efcdf2e3eab1e0fccd..3edcedd57d00b0657b7bd7e16509570a66629d93 100755 (executable)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+CFLAGS   = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS  += -Wall -g -I/usr/include/ncursesw
+
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+
+LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -19,15 +26,16 @@ else
        CFLAGS += -O2
 endif
 
-include /usr/share/dpatch/dpatch.make
-
-config.status: configure $(DPATCH_STAMPFN)
+config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc \
-               CFLAGS="$(CFLAGS)"
+               CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+
+build: build-arch build-indep
 
-build: build-stamp
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -36,7 +44,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -44,10 +52,11 @@ clean: unpatch
        $(MAKE) clean
        
        rm -f config.h config.log config.make config.status
-       rm -rf manual.html-chunked/
-       rm -f manual.pdf manual.html manual.toc
-       rm -f tig.1 tig.1.html tigrc.5 tigrc.5.html
-       rm -f NEWS.html README.html
+       rm -rf doc/manual.html-chunked/
+       rm -f doc/manual.pdf doc/manual.html doc/manual.toc
+       rm -f doc/tigmanual.7
+       rm -f doc/tig.1 doc/tig.1.html doc/tigrc.5 doc/tigrc.5.html
+       rm -f INSTALL.html NEWS.html README.html
        
        dh_clean 
 
@@ -58,6 +67,9 @@ install: build
        dh_installdirs
        
        $(MAKE) install install-doc DESTDIR=$(CURDIR)/debian/tig
+       # don't ship install instructions; README only links to them
+       rm -f debian/tig/usr/share/doc/tig/INSTALL.html \
+               debian/tig/usr/share/doc/tig/README.html
        
        mkdir -p debian/tig/etc/bash_completion.d
        cp contrib/tig-completion.bash debian/tig/etc/bash_completion.d/tig
@@ -69,8 +81,8 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs
-       dh_installdocs NEWS BUGS TODO manual.pdf
+       dh_installchangelogs NEWS.adoc
+       dh_installdocs doc/manual.pdf
        dh_installexamples contrib/tigrc
        dh_link
        dh_strip