Code

Switch to a simple, default dh debian/rules.
[pkg-src2tex.git] / debian / rules
index 2cbbaca8b5b4b669d37bb436a1398749180ccadf..cbe925d7587131c8ec8761915930894c60c096fd 100755 (executable)
@@ -1,60 +1,3 @@
 #!/usr/bin/make -f
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-CFLAGS = -Wall -g
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-       
-       $(MAKE) CFLAGS="$(CFLAGS)"
-       
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       
-       $(MAKE) clean
-       
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-       dh_install
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress -Xexamples
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
-
+%:
+       dh $@