Code

Merged branch 'experimental'.
[pkg-rrdtool.git] / debian / rules
index 996f23ce56d79cd11310ddb22cde23a7f52c9db1..e0701250de2a67f534cb811a690f8a6b271f877f 100755 (executable)
@@ -29,10 +29,11 @@ PY_VERS := $(shell pyversions -vr)
 TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
        | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
-
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_ARCH_CPU   ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
   CONFFLAGS += --build $(DEB_HOST_GNU_TYPE)
 else
@@ -57,7 +58,7 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
 #don't optimize on arm for now - #447041
-ifneq ($(DEB_HOST_GNU_TYPE), arm)
+ifneq ($(DEB_HOST_ARCH_CPU), arm)
         CFLAGS += -O2
 endif
 endif
@@ -128,6 +129,7 @@ endif
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
        rm -f src/librrd.sym
+       rm -f config.h
 
        dh_clean
 
@@ -152,6 +154,10 @@ install-common-stamp: build-arch-stamp
        # we don't want .txt and .pod documentation in the package
        rm -rf debian/tmp/usr/share/doc/rrdtool/txt
        dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
+       # remove duplicates
+       rm debian/rrdtool/usr/bin/rrdcached
+       rm debian/rrdtool/usr/share/man/man1/rrdcached.1
+       rm debian/rrdtool/usr/share/doc/rrdtool/html/rrdcached.html
 
        touch $@
 
@@ -168,6 +174,7 @@ install-arch: install-common-stamp $(PY_VERS:%=install-python%)
        done
 
        dh_installexamples -s
+       chmod 644 debian/rrdcached/usr/share/doc/rrdcached/examples/RRDCached.pm
 
 install-python%: install-common-stamp
        dh_testdir
@@ -211,11 +218,13 @@ binary-arch: build-arch install-arch
        dh_pysupport -prrdtool-dbg
        dh_perl -a
        dh_installman -a
+       dh_installinit -prrdcached
        dh_link -a
        dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a
+       dh_makeshlibs -a -Nliblua5.1-rrd0 -Nliblua5.1-rrd-dev
+       dh_makeshlibs -pliblua5.1-rrd0 -pliblua5.1-rrd-dev -n
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a