Code

control, rules: Switched from Ruby 1.9 to Ruby 1.9.1.
[pkg-rrdtool.git] / debian / rules
index 6430e061c28ccc5edb064bc0038e38e2f36ccf78..9c50f4057c67aed1769d98d0ee512f00bf23036a 100755 (executable)
@@ -7,9 +7,20 @@
 #we use quilt
 include /usr/share/quilt/quilt.make
 
+#needed to build with Python 2.6
+-include /usr/share/python/python.mk
+ifeq (,$(py_sitename))
+  py_sitename = site-packages
+  py_libdir = /usr/lib/python$(subst python,,$(1))/site-packages
+  py_sitename_sh = $(py_sitename)
+  py_libdir_sh = $(py_libdir)
+  py_setup_install_args = 
+endif
+
+
 
 #Ruby versions to build for
-RUBY_VERS := 1.8 1.9
+RUBY_VERS := 1.8 1.9.1
 RUBY_DEFAULT_VERS := 1.8
 
 PY_VERS := $(shell pyversions -vr)
@@ -170,8 +181,11 @@ install-python%: install-common-stamp
        dh_testroot
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool ;\
-        python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg
+        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool \
+               $(py_setup_install_args) ;\
+        python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg \
+               $(py_setup_install_args)
+
        find $(CURDIR)/debian/rrdtool-dbg -type f -name '*.egg-info' -print0 |\
                 xargs -0r rm -f