Code

More Lua binding stuff.
[pkg-rrdtool.git] / debian / rules
index 86d0382479b7b494a855b1970da2832f53152879..91816b5a082480c078d3f83a56c78360c720c2c8 100755 (executable)
@@ -18,7 +18,7 @@ PY_VERS := $(shell pyversions -vr)
 TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
        | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
-LUA = /usr/bin/lua5.1
+LUA = lua5.1
 
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -43,9 +43,6 @@ CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor
 #path to tcl
 CONFFLAGS += --with-tcllib=/usr/lib/tcl$(TCL_VERS)
 
-#enable lua installation
-CONFFLAGS += --enable-lua-site-install
-
 #let's take care of optimization + debug builds
 CFLAGS += -Wall -g
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -73,7 +70,7 @@ endif
        LDFLAGS="$(LINKER_FLAGS)" \
        CFLAGS="$(CFLAGS)" \
        RRDDOCDIR=/usr/share/doc/rrdtool \
-       LUA=$(LUA) \
+       LUA=/usr/bin/$(LUA) \
          ./configure $(CONFFLAGS)
 
 build: build-arch build-indep