Code

control: Updated standards-version to 3.9.5 -- no changes.
[pkg-rrdtool.git] / debian / rules
index 5c0aa75467148c88047694246d951b0a5c9ddd4f..8ddd00286d7d8a1bedaafd4864b46687b57cbc87 100755 (executable)
@@ -43,7 +43,7 @@ CONFFLAGS += --disable-python --disable-ruby
 CONFFLAGS += --prefix=/usr --docdir=/usr/share/doc/rrdtool
 
 #install perl libs in vendor mode
-CONFFLAGS += --with-perl-options=INSTALLDIRS=vendor 
+CONFFLAGS += --with-perl-options="INSTALLDIRS=vendor INSTALL_BASE="
 
 #path to tcl
 CONFFLAGS += --with-tcllib=/usr/lib/tcl$(TCL_VERS)
@@ -72,6 +72,8 @@ ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
 
+       dh_autoreconf
+
        LDFLAGS="$(LINKER_FLAGS)" \
        CFLAGS="$(CFLAGS)" \
        RRDDOCDIR=/usr/share/doc/rrdtool \
@@ -119,7 +121,8 @@ endif
 
        # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
-              bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old bindings/perl-shared/MYMETA.yml
+              bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
+       rm -f bindings/perl-shared/MYMETA.yml bindings/perl-shared/MYMETA.json
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
@@ -127,6 +130,8 @@ endif
        rm -f src/librrd.sym
        rm -f config.h
 
+       dh_autoreconf_clean
+
        dh_clean
 
 clean-python%: unpatch