Code

Build-conflict on lua50 as the lua binding autofoo stuff is buggy as hell.
[pkg-rrdtool.git] / debian / rules
index 4918fbe6756c5a8259e696af373aaee1e65d70b6..87e14dac5b6e043651570df4cb2fe0bcaac771bb 100755 (executable)
@@ -18,10 +18,11 @@ PY_VERS := $(shell pyversions -vr)
 TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
        | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
-
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_ARCH_CPU   ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
   CONFFLAGS += --build $(DEB_HOST_GNU_TYPE)
 else
@@ -46,7 +47,7 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
 #don't optimize on arm for now - #447041
-ifneq ($(DEB_HOST_GNU_TYPE), arm)
+ifneq ($(DEB_HOST_ARCH_CPU), arm)
         CFLAGS += -O2
 endif
 endif
@@ -87,13 +88,13 @@ build-python%: build-arch-stamp
        set -e ;\
         cd bindings/python ;\
         BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build ;\
-       touch $@
+        touch $@
 
 build-indep: build-arch-stamp
        #indep stuff is built in build-arch-stamp, too.
 
 clean: clean-patched
-clean-patched: unpatch $(PY_VERS:%=clean-python%)
+clean-patched: unpatch $(PY_VERS:%=clean-python%) $(PY_VERS:%=clean-python%-dbg)
        dh_testdir
        dh_testroot
 
@@ -117,14 +118,15 @@ endif
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
        rm -f src/librrd.sym
+       rm -f config.h
 
        dh_clean
 
 clean-python%: unpatch
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py clean
-       rm -f build-python$*
+        python$* setup.py clean ;\
+        rm -f build-python$*
 
 
 install: install-arch install-indep
@@ -141,6 +143,10 @@ install-common-stamp: build-arch-stamp
        # we don't want .txt and .pod documentation in the package
        rm -rf debian/tmp/usr/share/doc/rrdtool/txt
        dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
+       # remove duplicates
+       rm debian/rrdtool/usr/bin/rrdcached
+       rm debian/rrdtool/usr/share/man/man1/rrdcached.1
+       rm debian/rrdtool/usr/share/doc/rrdtool/html/rrdcached.html
 
        touch $@
 
@@ -157,6 +163,7 @@ install-arch: install-common-stamp $(PY_VERS:%=install-python%)
        done
 
        dh_installexamples -s
+       chmod 644 debian/rrdcached/usr/share/doc/rrdcached/examples/RRDCached.pm
 
 install-python%: install-common-stamp
        dh_testdir
@@ -165,16 +172,17 @@ install-python%: install-common-stamp
         cd bindings/python ;\
         python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool ;\
         python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg
+       find $(CURDIR)/debian/rrdtool-dbg -type f -name '*.egg-info' -print0 |\
+                xargs -0r rm -f
 
 
 binary-indep: build-indep install-indep
        dh_testdir
        dh_testroot
        dh_link -plibrrd-ruby /usr/share/doc/librrd-ruby$(RUBY_DEFAULT_VERS) /usr/share/doc/librrd-ruby
-       dh_link -ppython-rrd /usr/share/doc/python-rrdtool /usr/share/doc/python-rrd
-       dh_installchangelogs -i -Nlibrrd-ruby -Npython-rrd CHANGES
-       dh_installdocs -i -Nlibrrd-ruby -Npython-rrd -A CONTRIBUTORS NEWS
-       dh_link -i -Nlibrrd-ruby -Npython-rrd
+       dh_installchangelogs -i -Nlibrrd-ruby CHANGES
+       dh_installdocs -i -Nlibrrd-ruby -A CONTRIBUTORS NEWS
+       dh_link -i -Nlibrrd-ruby
        echo 'rubydefault:Depends=librrd-ruby$(RUBY_DEFAULT_VERS)' >> debian/librrd-ruby.substvars
        dh_perl -i
        dh_compress -i