Code

rules: Run dh_installinit for the "rrdcached" package.
[pkg-rrdtool.git] / debian / rules
index 1a361eb3805b661886be378ad29a8f86de097af4..6430e061c28ccc5edb064bc0038e38e2f36ccf78 100755 (executable)
@@ -18,7 +18,6 @@ PY_VERS := $(shell pyversions -vr)
 TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
        | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
-
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
@@ -144,6 +143,10 @@ install-common-stamp: build-arch-stamp
        # we don't want .txt and .pod documentation in the package
        rm -rf debian/tmp/usr/share/doc/rrdtool/txt
        dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
+       # remove duplicates
+       rm debian/rrdtool/usr/bin/rrdcached
+       rm debian/rrdtool/usr/share/man/man1/rrdcached.1
+       rm debian/rrdtool/usr/share/doc/rrdtool/html/rrdcached.html
 
        touch $@
 
@@ -160,6 +163,7 @@ install-arch: install-common-stamp $(PY_VERS:%=install-python%)
        done
 
        dh_installexamples -s
+       chmod 644 debian/rrdcached/usr/share/doc/rrdcached/examples/RRDCached.pm
 
 install-python%: install-common-stamp
        dh_testdir
@@ -200,11 +204,13 @@ binary-arch: build-arch install-arch
        dh_pysupport -prrdtool-dbg
        dh_perl -a
        dh_installman -a
+       dh_installinit -prrdcached
        dh_link -a
        dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a
+       dh_makeshlibs -a -Nliblua5.1-rrd0 -Nliblua5.1-rrd-dev
+       dh_makeshlibs -pliblua5.1-rrd0 -pliblua5.1-rrd-dev -n
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a