Code

Ack NMU.
[pkg-rrdtool.git] / debian / rules
index 87e14dac5b6e043651570df4cb2fe0bcaac771bb..6178929965ac2919084165c0a142c97860fcebf8 100755 (executable)
@@ -7,9 +7,20 @@
 #we use quilt
 include /usr/share/quilt/quilt.make
 
+#needed to build with Python 2.6
+-include /usr/share/python/python.mk
+ifeq (,$(py_sitename))
+  py_sitename = site-packages
+  py_libdir = /usr/lib/python$(subst python,,$(1))/site-packages
+  py_sitename_sh = $(py_sitename)
+  py_libdir_sh = $(py_libdir)
+  py_setup_install_args = 
+endif
+
+
 
 #Ruby versions to build for
-RUBY_VERS := 1.8 1.9
+RUBY_VERS := 1.8 1.9.1
 RUBY_DEFAULT_VERS := 1.8
 
 PY_VERS := $(shell pyversions -vr)
@@ -142,7 +153,7 @@ install-common-stamp: build-arch-stamp
        make install DESTDIR=$(CURDIR)/debian/tmp
        # we don't want .txt and .pod documentation in the package
        rm -rf debian/tmp/usr/share/doc/rrdtool/txt
-       dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
+       dh_install --sourcedir=$(CURDIR)/debian/tmp -X.la --fail-missing
        # remove duplicates
        rm debian/rrdtool/usr/bin/rrdcached
        rm debian/rrdtool/usr/share/man/man1/rrdcached.1
@@ -170,8 +181,11 @@ install-python%: install-common-stamp
        dh_testroot
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool ;\
-        python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg
+        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool \
+               $(py_setup_install_args) ;\
+        python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg \
+               $(py_setup_install_args)
+
        find $(CURDIR)/debian/rrdtool-dbg -type f -name '*.egg-info' -print0 |\
                 xargs -0r rm -f
 
@@ -204,11 +218,13 @@ binary-arch: build-arch install-arch
        dh_pysupport -prrdtool-dbg
        dh_perl -a
        dh_installman -a
+       dh_installinit -prrdcached
        dh_link -a
        dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a
+       dh_makeshlibs -a -Nliblua5.1-rrd0 -Nliblua5.1-rrd-dev
+       dh_makeshlibs -pliblua5.1-rrd0 -pliblua5.1-rrd-dev -n
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a