Code

Added build_ldadd patch adding ALL_LIBS to rrdcached_LDADD.
[pkg-rrdtool.git] / debian / rules
index db29a2455dfef68d8c1fc1676ecb820c17226d13..390eb8d46a8a4f39240c20df6c5edac4a62feb45 100755 (executable)
@@ -7,10 +7,17 @@
 #we use quilt
 include /usr/share/quilt/quilt.make
 
+#needed to build with Python 2.6
+-include /usr/share/python/python.mk
+ifeq (,$(py_sitename))
+  py_sitename = site-packages
+  py_libdir = /usr/lib/python$(subst python,,$(1))/site-packages
+  py_sitename_sh = $(py_sitename)
+  py_libdir_sh = $(py_libdir)
+  py_setup_install_args = 
+endif
+
 
-#Ruby versions to build for
-RUBY_VERS := 1.8 1.9
-RUBY_DEFAULT_VERS := 1.8
 
 PY_VERS := $(shell pyversions -vr)
 
@@ -18,10 +25,11 @@ PY_VERS := $(shell pyversions -vr)
 TCL_VERS := $(shell dpkg -s tcl-dev | grep '^Depends' \
        | sed 's,.*\<tcl\([0-9.]*\)-dev\>.*,\1,')
 
-
 #let's help configure to figure out our host/build system
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_ARCH_CPU   ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
   CONFFLAGS += --build $(DEB_HOST_GNU_TYPE)
 else
@@ -46,7 +54,7 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
 else
 #don't optimize on arm for now - #447041
-ifneq ($(DEB_HOST_GNU_TYPE), arm)
+ifneq ($(DEB_HOST_ARCH_CPU), arm)
         CFLAGS += -O2
 endif
 endif
@@ -64,6 +72,8 @@ ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
 
+       dh_autoreconf
+
        LDFLAGS="$(LINKER_FLAGS)" \
        CFLAGS="$(CFLAGS)" \
        RRDDOCDIR=/usr/share/doc/rrdtool \
@@ -71,7 +81,7 @@ endif
 
 build: build-arch build-indep 
 
-build-arch: build-arch-stamp $(PY_VERS:%=build-python%)
+build-arch: build-arch-stamp $(PY_VERS:%=build-python%) $(PY_VERS:%=build-python%-dbg)
 build-arch-stamp: config.status 
        make
        #Fix library path to tcl bindings
@@ -86,14 +96,14 @@ build-arch-stamp: config.status
 build-python%: build-arch-stamp
        set -e ;\
         cd bindings/python ;\
-        BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build
-       touch $@
+        BUILDLIBDIR=../../src/.libs LIBDIR=../../src/.libs python$* setup.py build ;\
+        touch $@
 
 build-indep: build-arch-stamp
        #indep stuff is built in build-arch-stamp, too.
 
 clean: clean-patched
-clean-patched: unpatch $(PY_VERS:%=clean-python%)
+clean-patched: unpatch $(PY_VERS:%=clean-python%) $(PY_VERS:%=clean-python%-dbg)
        dh_testdir
        dh_testroot
 
@@ -111,20 +121,23 @@ endif
 
        # clean what the Makefiles do not clean ...
        rm -rf bindings/perl-piped/blib bindings/perl-shared/blib \
-              bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old
+              bindings/perl-piped/Makefile.old bindings/perl-shared/Makefile.old bindings/perl-shared/MYMETA.yml
        rm -f bindings/tcl/pkgIndex.tcl bindings/tcl/tclrrd*.so
        rm -f examples/cgi-demo.cgi
        rm -rf src/.libs src/.deps doc/*.html doc/*.1 doc/*.txt
        rm -f intltool-extract intltool-merge intltool-update
        rm -f src/librrd.sym
+       rm -f config.h
+
+       dh_autoreconf_clean
 
        dh_clean
 
 clean-python%: unpatch
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py clean
-       rm -f build-python$*
+        python$* setup.py clean ;\
+        rm -f build-python$*
 
 
 install: install-arch install-indep
@@ -140,40 +153,41 @@ install-common-stamp: build-arch-stamp
        make install DESTDIR=$(CURDIR)/debian/tmp
        # we don't want .txt and .pod documentation in the package
        rm -rf debian/tmp/usr/share/doc/rrdtool/txt
-       dh_install --sourcedir=$(CURDIR)/debian/tmp --fail-missing
+       dh_install --sourcedir=$(CURDIR)/debian/tmp -X.la --fail-missing
+       # remove duplicates
+       rm debian/rrdtool/usr/bin/rrdcached
+       rm debian/rrdtool/usr/share/man/man1/rrdcached.1
+       rm debian/rrdtool/usr/share/doc/rrdtool/html/rrdcached.html
 
        touch $@
 
 install-arch: install-common-stamp $(PY_VERS:%=install-python%)
        #build and install ruby
-       set -e; \
-       cd bindings/ruby ;\
-       for rbv in $(RUBY_VERS); do \
-         ruby$$rbv extconf.rb ;\
-         make ;\
-         make install sitelibdir=$(CURDIR)/debian/librrd-ruby$$rbv`ruby$$rbv -r rbconfig -e 'print Config::CONFIG["rubylibdir"]'` \
-                      sitearchdir=$(CURDIR)/debian/librrd-ruby$$rbv`ruby$$rbv -r rbconfig -e 'print Config::CONFIG["archdir"]'` ;\
-         make distclean ;\
-       done
+       dh_ruby --install
 
        dh_installexamples -s
+       chmod 644 debian/rrdcached/usr/share/doc/rrdcached/examples/RRDCached.pm
 
 install-python%: install-common-stamp
        dh_testdir
        dh_testroot
        set -e ;\
         cd bindings/python ;\
-        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool
+        python$* setup.py install --root=$(CURDIR)/debian/python-rrdtool \
+               $(py_setup_install_args) ;\
+        python$*-dbg setup.py install --root=$(CURDIR)/debian/rrdtool-dbg \
+               $(py_setup_install_args)
+
+       find $(CURDIR)/debian/rrdtool-dbg -type f -name '*.egg-info' -print0 |\
+                xargs -0r rm -f
 
 
 binary-indep: build-indep install-indep
        dh_testdir
        dh_testroot
-       dh_link -plibrrd-ruby /usr/share/doc/librrd-ruby$(RUBY_DEFAULT_VERS) /usr/share/doc/librrd-ruby
-       dh_installchangelogs -i -Nlibrrd-ruby CHANGES
-       dh_installdocs -i -Nlibrrd-ruby -A CONTRIBUTORS NEWS
-       dh_link -i -Nlibrrd-ruby
-       echo 'rubydefault:Depends=librrd-ruby$(RUBY_DEFAULT_VERS)' >> debian/librrd-ruby.substvars
+       dh_installchangelogs -i CHANGES
+       dh_installdocs -i -A CONTRIBUTORS NEWS
+       dh_link -i
        dh_perl -i
        dh_compress -i
        dh_fixperms -i
@@ -190,14 +204,17 @@ binary-arch: build-arch install-arch
        dh_installdocs -a -A CONTRIBUTORS NEWS
        dh_installdocs -a
        echo 'tcl:Depends=tcl$(TCL_VERS) | tclsh' >> debian/rrdtool-tcl.substvars
-       dh_pysupport -ppython-rrdtool
+       dh_python2 -ppython-rrdtool
+       dh_python2 -prrdtool-dbg
        dh_perl -a
        dh_installman -a
+       dh_installinit -prrdcached
        dh_link -a
        dh_strip -a --dbg-package=rrdtool-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a
+       dh_makeshlibs -a -Nliblua5.1-rrd0 -Nliblua5.1-rrd-dev
+       dh_makeshlibs -pliblua5.1-rrd0 -pliblua5.1-rrd-dev -n
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a