Code

rules: Enable chat-screen feature.
[pkg-ncmpc.git] / debian / rules
index c77ceda48e3681e47e6e3cd5dec861ec315b9672..9c42b7b3796394323e2d41f50223cf2c91a9ae00 100755 (executable)
@@ -25,7 +25,9 @@ ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
        CHECK =
 endif
 
-config.status: configure
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
@@ -40,6 +42,7 @@ config.status: configure
                        --enable-help-screen \
                        --enable-mouse \
                        --enable-artist-screen \
+                       --enable-chat-screen \
                        --enable-search-screen \
                        --enable-song-screen \
                        --enable-key-screen \
@@ -58,7 +61,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp