Code

rules: Enable chat-screen feature.
[pkg-ncmpc.git] / debian / rules
index 7399bd58eef8986c0ff3165c31538ed2e5abf0ae..9c42b7b3796394323e2d41f50223cf2c91a9ae00 100755 (executable)
@@ -19,9 +19,17 @@ else
        CFLAGS += -O2
 endif
 
-config.status: configure
+CHECK = check
+
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+       CHECK =
+endif
+
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
+       ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
                        --disable-mini \
@@ -34,12 +42,14 @@ config.status: configure
                        --enable-help-screen \
                        --enable-mouse \
                        --enable-artist-screen \
+                       --enable-chat-screen \
                        --enable-search-screen \
                        --enable-song-screen \
                        --enable-key-screen \
                        --enable-lyrics-screen \
                        --enable-outputs-screen \
-                       --with-ncursesw
+                       --with-ncursesw \
+                       CFLAGS="$(CFLAGS)"
 
 build: build-stamp
 
@@ -47,10 +57,11 @@ build-stamp: config.status
        dh_testdir
        
        $(MAKE)
+       test -z '$(CHECK)' || make $(CHECK)
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -62,7 +73,7 @@ clean:
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        
        mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/