Code

rules: Enable chat-screen feature.
[pkg-ncmpc.git] / debian / rules
index 502ee01ecc4287f46a7c5e844c0dc88d79c34124..9c42b7b3796394323e2d41f50223cf2c91a9ae00 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for ncmpc
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g -I/usr/include/ncursesw
+CFLAGS = -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -19,12 +19,37 @@ else
        CFLAGS += -O2
 endif
 
-config.status: configure
+CHECK = check
+
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+       CHECK =
+endif
+
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
+       ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
-                       --enable-search-screen --enable-artist-screen
+                       --disable-mini \
+                       --enable-wide \
+                       --enable-multibyte \
+                       --enable-locale \
+                       --enable-nls \
+                       --enable-colors \
+                       --enable-lirc \
+                       --enable-help-screen \
+                       --enable-mouse \
+                       --enable-artist-screen \
+                       --enable-chat-screen \
+                       --enable-search-screen \
+                       --enable-song-screen \
+                       --enable-key-screen \
+                       --enable-lyrics-screen \
+                       --enable-outputs-screen \
+                       --with-ncursesw \
+                       CFLAGS="$(CFLAGS)"
 
 build: build-stamp
 
@@ -32,37 +57,60 @@ build-stamp: config.status
        dh_testdir
        
        $(MAKE)
+       test -z '$(CHECK)' || make $(CHECK)
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
        
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
        
-       dh_clean 
+       dh_clean
 
-install: build
+install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_prep
+       dh_installdirs -i
+       
+       mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/
+       cp lyrics/* debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/
+
+install-arch: build
+       dh_testdir
+       dh_testroot
+       dh_prep
        dh_installdirs -a
        
        $(MAKE) install DESTDIR=$(CURDIR)/debian/ncmpc
        
-       mkdir $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/examples
-       mv $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/*.sample \
-               $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/examples
-       mv $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/ncmpc.lirc \
-               $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/examples
-       rm $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/AUTHORS
+       rm -rf debian/ncmpc/usr/lib/ncmpc/lyrics/
+       # fail if any of these directories is not empty
+       rmdir debian/ncmpc/usr/lib/ncmpc/
+       rmdir debian/ncmpc/usr/lib/
        
-binary-indep:
-       # nothing to do here
+       mkdir debian/ncmpc/usr/share/doc/ncmpc/examples
+       mv debian/ncmpc/usr/share/doc/ncmpc/*.sample \
+               debian/ncmpc/usr/share/doc/ncmpc/examples
+       mv debian/ncmpc/usr/share/doc/ncmpc/ncmpc.lirc \
+               debian/ncmpc/usr/share/doc/ncmpc/examples
+
+binary-indep: install-indep
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs -i
+       dh_installdocs -A -i NEWS README AUTHORS
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
-binary-arch: build install
+binary-arch: build install-arch
        dh_testdir
        dh_testroot
        dh_installchangelogs -a
@@ -79,5 +127,5 @@ binary-arch: build install
        dh_builddeb -a
 
 binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install
+.PHONY: build clean binary-indep binary-arch binary install-indep install-arch