Code

rules: Use dh_prep instead of 'dh_clean -k' in all places.
[pkg-ncmpc.git] / debian / rules
index 7399bd58eef8986c0ff3165c31538ed2e5abf0ae..9296d1515d69ec46b4f40a81b853f5fca5c2c0e1 100755 (executable)
@@ -21,7 +21,7 @@ endif
 
 config.status: configure
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
+       ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
                        --disable-mini \
@@ -39,7 +39,8 @@ config.status: configure
                        --enable-key-screen \
                        --enable-lyrics-screen \
                        --enable-outputs-screen \
-                       --with-ncursesw
+                       --with-ncursesw \
+                       CFLAGS="$(CFLAGS)"
 
 build: build-stamp
 
@@ -62,7 +63,7 @@ clean:
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        
        mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/