Code

rules: Removed unnecessary occurrences of $(CURDIR).
[pkg-ncmpc.git] / debian / rules
index 9749a967b0e81ccca8301c9d6f9c33257d3b3508..6a56e5544ba7e1336922d387521686b3cd250e36 100755 (executable)
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g -I/usr/include/ncursesw
+CFLAGS = -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -24,7 +24,22 @@ config.status: configure
        CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
-                       --enable-search-screen --enable-artist-screen
+                       --disable-mini \
+                       --enable-wide \
+                       --enable-multibyte \
+                       --enable-locale \
+                       --enable-nls \
+                       --enable-colors \
+                       --enable-lirc \
+                       --enable-help-screen \
+                       --enable-mouse \
+                       --enable-artist-screen \
+                       --enable-search-screen \
+                       --enable-song-screen \
+                       --enable-key-screen \
+                       --enable-lyrics-screen \
+                       --enable-outputs-screen \
+                       --with-ncursesw
 
 build: build-stamp
 
@@ -40,24 +55,24 @@ clean:
        dh_testroot
        rm -f build-stamp
        
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
        
-       dh_clean 
+       dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs -a
        
        $(MAKE) install DESTDIR=$(CURDIR)/debian/ncmpc
        
-       mkdir $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/examples
-       mv $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/*.sample \
-               $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/examples
-       mv $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/ncmpc.lirc \
-               $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/examples
-       rm $(CURDIR)/debian/ncmpc/usr/share/doc/ncmpc/AUTHORS
+       mkdir debian/ncmpc/usr/share/doc/ncmpc/examples
+       mv debian/ncmpc/usr/share/doc/ncmpc/*.sample \
+               debian/ncmpc/usr/share/doc/ncmpc/examples
+       mv debian/ncmpc/usr/share/doc/ncmpc/ncmpc.lirc \
+               debian/ncmpc/usr/share/doc/ncmpc/examples
+       rm debian/ncmpc/usr/share/doc/ncmpc/AUTHORS
        
 binary-indep:
        # nothing to do here
@@ -66,7 +81,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs -a
-       dh_installdocs -A -a NEWS README TODO
+       dh_installdocs -A -a NEWS README
        dh_installmenu -a
        dh_link -a
        dh_strip -a