Code

rules: Explicitly enable all features when running the configure script.
[pkg-ncmpc.git] / debian / rules
index b26cb650d03597615b626f11b41e0e0ced97eef9..59166c008eca230fd93639e5f504f5707258ea20 100755 (executable)
@@ -11,7 +11,7 @@
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g -I/usr/include/ncursesw
+CFLAGS = -Wall -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -24,7 +24,18 @@ config.status: configure
        CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
-                       --enable-search-screen --enable-artist-screen
+                       --enable-wide \
+                       --enable-nls \
+                       --enable-colors \
+                       --enable-lirc \
+                       --enable-help-screen \
+                       --enable-mouse \
+                       --enable-artist-screen \
+                       --enable-search-screen \
+                       --enable-song-screen \
+                       --enable-key-screen \
+                       --enable-lyrics-screen \
+                       --with-ncursesw
 
 build: build-stamp