Code

rules: Do not install leoslyrics plugins.
[pkg-ncmpc.git] / debian / rules
index 23f2f13399c4778f22902595cfdfe005f872efea..56a9065319950a6f224d533522c0907b5a2caf15 100755 (executable)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
 CHECK = check
 
@@ -25,9 +22,7 @@ ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
        CHECK =
 endif
 
-include /usr/share/dpatch/dpatch.make
-
-config.status: configure $(DPATCH_STAMPFN)
+config.status: configure
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
@@ -42,15 +37,21 @@ config.status: configure $(DPATCH_STAMPFN)
                        --enable-help-screen \
                        --enable-mouse \
                        --enable-artist-screen \
+                       --enable-chat-screen \
                        --enable-search-screen \
                        --enable-song-screen \
                        --enable-key-screen \
                        --enable-lyrics-screen \
                        --enable-outputs-screen \
+                       --enable-documentation \
                        --with-ncursesw \
-                       CFLAGS="$(CFLAGS)"
+                       CPPFLAGS="$(CPPFLAGS)" \
+                       CFLAGS="$(CFLAGS)" \
+                       LDFLAGS="$(LDFLAGS)"
 
-build: build-stamp
+build: build-arch build-indep
+build-indep:
+build-arch: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -60,7 +61,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -77,6 +78,8 @@ install-indep:
        
        mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/
        cp lyrics/* debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/
+       # Leo's Lyrics's API seems to be down; https://bugs.debian.org/654243
+       rm -f debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/*leoslyrics*
 
 install-arch: build
        dh_testdir