Code

rules: Do not install leoslyrics plugins.
[pkg-ncmpc.git] / debian / rules
index 02ed5ce9431b4330975d5a5edf5051849edb593a..56a9065319950a6f224d533522c0907b5a2caf15 100755 (executable)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
 CHECK = check
 
@@ -48,9 +45,13 @@ config.status: configure
                        --enable-outputs-screen \
                        --enable-documentation \
                        --with-ncursesw \
-                       CFLAGS="$(CFLAGS)"
+                       CPPFLAGS="$(CPPFLAGS)" \
+                       CFLAGS="$(CFLAGS)" \
+                       LDFLAGS="$(LDFLAGS)"
 
-build: build-stamp
+build: build-arch build-indep
+build-indep:
+build-arch: build-stamp
 
 build-stamp: config.status
        dh_testdir
@@ -77,6 +78,8 @@ install-indep:
        
        mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/
        cp lyrics/* debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/
+       # Leo's Lyrics's API seems to be down; https://bugs.debian.org/654243
+       rm -f debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/*leoslyrics*
 
 install-arch: build
        dh_testdir