Code

rules: Pass CFLAGS as arguments to configure.
[pkg-ncmpc.git] / debian / rules
index 7399bd58eef8986c0ff3165c31538ed2e5abf0ae..36f2d5b2bdd82ba84bdbc586cd3a2dfca394a073 100755 (executable)
@@ -21,7 +21,7 @@ endif
 
 config.status: configure
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
+       ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
                        --disable-mini \
@@ -39,7 +39,8 @@ config.status: configure
                        --enable-key-screen \
                        --enable-lyrics-screen \
                        --enable-outputs-screen \
-                       --with-ncursesw
+                       --with-ncursesw \
+                       CFLAGS="$(CFLAGS)"
 
 build: build-stamp