Code

changelog: The new upstream release fixes #638830.
[pkg-ncmpc.git] / debian / rules
index 36f2d5b2bdd82ba84bdbc586cd3a2dfca394a073..271e3f8fda144aa3b0bf4fd72e0278cca7b2e78c 100755 (executable)
@@ -19,7 +19,15 @@ else
        CFLAGS += -O2
 endif
 
-config.status: configure
+CHECK = check
+
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+       CHECK =
+endif
+
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
@@ -34,11 +42,13 @@ config.status: configure
                        --enable-help-screen \
                        --enable-mouse \
                        --enable-artist-screen \
+                       --enable-chat-screen \
                        --enable-search-screen \
                        --enable-song-screen \
                        --enable-key-screen \
                        --enable-lyrics-screen \
                        --enable-outputs-screen \
+                       --enable-documentation \
                        --with-ncursesw \
                        CFLAGS="$(CFLAGS)"
 
@@ -48,10 +58,11 @@ build-stamp: config.status
        dh_testdir
        
        $(MAKE)
+       test -z '$(CHECK)' || make $(CHECK)
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -63,7 +74,7 @@ clean:
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        
        mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/