Code

patches: Added include_config_h.dpatch.
[pkg-ncmpc.git] / debian / rules
index c77ceda48e3681e47e6e3cd5dec861ec315b9672..23f2f13399c4778f22902595cfdfe005f872efea 100755 (executable)
@@ -25,7 +25,9 @@ ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
        CHECK =
 endif
 
-config.status: configure
+include /usr/share/dpatch/dpatch.make
+
+config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
@@ -58,7 +60,7 @@ build-stamp: config.status
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp