Code

Remove dh_autoreconf which isn't needed anymore.
[pkg-ncmpc.git] / debian / rules
index 36f2d5b2bdd82ba84bdbc586cd3a2dfca394a073..042e001a95056c29fe03b619e3bc9ac79d91178e 100755 (executable)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
+CFLAGS += -Wall
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
+CHECK = check
+
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+       CHECK =
 endif
 
 config.status: configure
@@ -34,20 +37,27 @@ config.status: configure
                        --enable-help-screen \
                        --enable-mouse \
                        --enable-artist-screen \
+                       --enable-chat-screen \
                        --enable-search-screen \
                        --enable-song-screen \
                        --enable-key-screen \
                        --enable-lyrics-screen \
                        --enable-outputs-screen \
+                       --enable-documentation \
                        --with-ncursesw \
-                       CFLAGS="$(CFLAGS)"
+                       CPPFLAGS="$(CPPFLAGS)" \
+                       CFLAGS="$(CFLAGS)" \
+                       LDFLAGS="$(LDFLAGS)"
 
-build: build-stamp
+build: build-arch build-indep
+build-indep:
+build-arch: build-stamp
 
 build-stamp: config.status
        dh_testdir
        
        $(MAKE)
+       test -z '$(CHECK)' || make $(CHECK)
        
        touch build-stamp
 
@@ -63,7 +73,7 @@ clean:
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        
        mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/