Code

Drop bts589660-updated-manpage; merged upstream.
[pkg-ncmpc.git] / debian / rules
index b06f979fc9083cdb8c4a3d8c63473d9f3afb0d72..02ed5ce9431b4330975d5a5edf5051849edb593a 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for ncmpc
 #
-# Written by Sebastian Harl <sh@tokkee.org>
+# Written by Sebastian Harl <tokkee@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -19,9 +19,15 @@ else
        CFLAGS += -O2
 endif
 
+CHECK = check
+
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+       CHECK =
+endif
+
 config.status: configure
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
+       ./configure --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
                        --mandir=\$${prefix}/share/man \
                        --disable-mini \
@@ -34,12 +40,15 @@ config.status: configure
                        --enable-help-screen \
                        --enable-mouse \
                        --enable-artist-screen \
+                       --enable-chat-screen \
                        --enable-search-screen \
                        --enable-song-screen \
                        --enable-key-screen \
                        --enable-lyrics-screen \
                        --enable-outputs-screen \
-                       --with-ncursesw
+                       --enable-documentation \
+                       --with-ncursesw \
+                       CFLAGS="$(CFLAGS)"
 
 build: build-stamp
 
@@ -47,6 +56,7 @@ build-stamp: config.status
        dh_testdir
        
        $(MAKE)
+       test -z '$(CHECK)' || make $(CHECK)
        
        touch build-stamp
 
@@ -62,7 +72,7 @@ clean:
 install-indep:
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs -i
        
        mkdir -p debian/ncmpc-lyrics/usr/lib/ncmpc/lyrics/