Code

changelog: Updated timestamp.
[pkg-libkohana2-php.git] / debian / rules
index a8ede19ee6a6fb942e98f22d9e302153856d5418..7a2c9c9c3d4a4532875abd35c3b65ae3cfd259b5 100755 (executable)
@@ -9,7 +9,9 @@
 get-orig-source:
        uscan --force --verbose --repack --rename
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp:
        dh_testdir
 
@@ -33,7 +35,23 @@ install: build
        # install modules
        cp -a modules debian/libkohana2-modules-php/usr/share/php/kohana2/
 
-       # remove DejaVu-Fonts and create symlink
+       # move config to /etc
+       mv debian/libkohana2-php/usr/share/php/kohana2/system/config \
+               debian/libkohana2-php/etc/kohana2/system
+       ln -s /etc/kohana2/system/config \
+               debian/libkohana2-php/usr/share/php/kohana2/system/config
+
+       ( \
+               set -e; \
+               cd debian/libkohana2-modules-php/usr/share/php/kohana2/modules; \
+               for config in */config; do \
+                       mkdir ../../../../../etc/kohana2/modules/$${config%\/*}; \
+                       mv $$config ../../../../../etc/kohana2/modules/$${config%\/*}; \
+                       ln -s /etc/kohana2/modules/$$config $$config; \
+               done \
+       )
+
+       # remove local copy of the DejaVu fonts
        rm -rf debian/libkohana2-php/usr/share/php/kohana2/system/fonts
 
        # replace jQuery with a symlink to the JavaScript provided by libjs-jquery