Code

rules: Do not use $(CURDIR).
[pkg-libkohana2-php.git] / debian / rules
index 2620bed4dc48d4e37f6ba34bafd89b9feaf88627..63c17c3f773c663c54af3056b1a126246dc8ff1e 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
+# debian/rules for kohana2
+#
+# Written by Sven Velt <sven@velt.de> and Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -7,28 +9,16 @@
 get-orig-source:
        uscan --force --verbose --repack --rename
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
 build: build-stamp
-build-stamp: configure-stamp
+build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
-       #$(MAKE)
-       #docbook-to-man debian/libkohana-php.sgml > libkohana-php.1
-
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
 
        dh_clean
 
@@ -38,50 +28,49 @@ install: build
        dh_prep
        dh_installdirs
 
-       # Add here commands to install the package into debian/libkohana2-php.
-       cp -a system $(CURDIR)/debian/libkohana2-php/usr/share/php/kohana2/
-       # Remove DejaVu-Fonts and create symlink
-       rm -rf $(CURDIR)/debian/libkohana2-php/usr/share/php/kohana2/system/fonts
-       ln -s /usr/share/fonts/truetype/ttf-dejavu $(CURDIR)/debian/libkohana2-php/usr/share/php/kohana2/system/fonts
+       cp -a system debian/libkohana2-php/usr/share/php/kohana2/
+
+       # remove DejaVu-Fonts and create symlink
+       rm -rf debian/libkohana2-php/usr/share/php/kohana2/system/fonts
+
+       cp -a modules debian/libkohana2-modules-php/usr/share/php/kohana2/
+       rm -f debian/libkohana2-modules-php/usr/share/php/kohana2/modules/kodoc/views/kodoc/media/js/jquery.js
+       ln -s /usr/share/javascript/jquery/jquery.js \
+               debian/libkohana2-modules-php/usr/share/php/kohana2/modules/kodoc/views/kodoc/media/js/jquery.js
 
        # fix permissions
-       for file in `find $(CURDIR)/debian/libkohana2-php -name '*.php'`; do \
+       for file in `find debian/libkohana2-* -name '*.php'`; do \
                chmod 644 $$file; \
        done
 
-# Build architecture-independent files here.
+       # remove empty directories
+       rmdir debian/libkohana2-php/usr/share/php/kohana2/system/i18n/el_GR/
+       rmdir debian/libkohana2-php/usr/share/php/kohana2/system/tests/
+
+       rmdir debian/libkohana2-modules-php/usr/share/php/kohana2/modules/archive/i18n/el_GR/
+       rmdir debian/libkohana2-modules-php/usr/share/php/kohana2/modules/auth/controllers/
+       rmdir debian/libkohana2-modules-php/usr/share/php/kohana2/modules/auth/views/
+       rmdir debian/libkohana2-modules-php/usr/share/php/kohana2/modules/kodoc/views/kodoc/media/css/
+       rmdir debian/libkohana2-modules-php/usr/share/php/kohana2/modules/payment/i18n/el_GR/
+       rmdir debian/libkohana2-modules-php/usr/share/php/kohana2/modules/payment/i18n/es_AR/
+       rmdir debian/libkohana2-modules-php/usr/share/php/kohana2/modules/payment/i18n/zh_CN/
+
 binary-indep: install
        dh_testdir
        dh_testroot
        dh_installchangelogs
        dh_installdocs
        dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-#      dh_installwm
-#      dh_installudev
        dh_lintian
-#      dh_undocumented
        dh_installman
        dh_link
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_python
        dh_installdeb
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-# Build architecture-dependent files here.
 binary-arch: install
 
 binary: binary-indep binary-arch