Code

rules: Fix permissions of all PHP files.
[pkg-libkohana2-php.git] / debian / rules
index 4ed05371a5027f94e0cb2b70e31b564149aec435..2620bed4dc48d4e37f6ba34bafd89b9feaf88627 100755 (executable)
@@ -44,6 +44,10 @@ install: build
        rm -rf $(CURDIR)/debian/libkohana2-php/usr/share/php/kohana2/system/fonts
        ln -s /usr/share/fonts/truetype/ttf-dejavu $(CURDIR)/debian/libkohana2-php/usr/share/php/kohana2/system/fonts
 
+       # fix permissions
+       for file in `find $(CURDIR)/debian/libkohana2-php -name '*.php'`; do \
+               chmod 644 $$file; \
+       done
 
 # Build architecture-independent files here.
 binary-indep: install