Code

rules: Use 'filter' rather than 'findstring'.
[pkg-fusedav.git] / debian / rules
index 428c5ec80f42e0d3929952962784d31281a4ddcd..a43f7f4a8aaf1e77ccc3da6bce1948b511b93d19 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for fusedav
 #
-# Written by Sebastian Harl <sh@tokkee.org>.
+# Written by Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -15,7 +15,7 @@ CFLAGS = -Wall -g
 
 BUILDDIR = ./debian/build/
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
@@ -26,7 +26,7 @@ include /usr/share/dpatch/dpatch.make
 $(BUILDDIR)/config.status: configure patch
        dh_testdir
        [ -e $(BUILDDIR) ] || mkdir $(BUILDDIR)
-       touch aclocal.m4 configure Makefile.in
+       touch aclocal.m4 configure config.h.in Makefile.in
        cd $(BUILDDIR) && CFLAGS="$(CFLAGS)" ../../configure \
                        --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) \