Code

rules: No longer patching configure ⇒ don't touch(1)ing autotools files.
[pkg-fusedav.git] / debian / rules
index 7fb0faa19a23de0ec3d6eaebd62827098e12f858..4fbde9998e76cbb3b590e16a2c6d98f87813fe97 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 # debian/rules for fusedav
 #
-# Written by Sebastian Harl <sh@tokkee.org>.
+# Written by Sebastian Harl <tokkee@debian.org>.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -15,7 +15,7 @@ CFLAGS = -Wall -g
 
 BUILDDIR = ./debian/build/
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
@@ -26,7 +26,6 @@ include /usr/share/dpatch/dpatch.make
 $(BUILDDIR)/config.status: configure patch
        dh_testdir
        [ -e $(BUILDDIR) ] || mkdir $(BUILDDIR)
-       touch aclocal.m4 configure config.h.in Makefile.in
        cd $(BUILDDIR) && CFLAGS="$(CFLAGS)" ../../configure \
                        --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) \