Code

control/rules: Let enblend/enfuse use the Boost filesystem library.
[pkg-enblend.git] / debian / rules
index 08084df05c730de6e21a145f6b072fd32d2737d4..9ff9e0025b9d32955ed7ef3c50dfcb9f32e44c5c 100755 (executable)
@@ -31,7 +31,12 @@ config.status: configure $(DPATCH_STAMPFN)
        dh_testdir
        CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/usr --mandir=\$${prefix}/share/man
+               --prefix=/usr --mandir=\$${prefix}/share/man \
+               --enable-gpu-support=yes \
+               --disable-openmp \
+               --enable-image-cache=yes \
+               --with-boost-filesystem=yes \
+               --with-openexr=yes
 
 build: build-stamp
 
@@ -67,22 +72,22 @@ binary-indep:
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs ChangeLog
-       dh_installdocs NEWS AUTHORS
-       dh_installexamples
-       dh_install --sourcedir=debian/tmp --fail-missing
-       dh_installman
+       dh_installchangelogs -a ChangeLog
+       dh_installdocs -A -a NEWS AUTHORS
+       dh_installexamples -a
+       dh_install -a --sourcedir=debian/tmp --fail-missing
+       dh_installman -a
        dh_installinfo -penblend doc/enblend.info
        dh_installinfo -penfuse doc/enfuse*.info
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+       dh_link -a
+       dh_strip -a
+       dh_compress -a
+       dh_fixperms -a
+       dh_installdeb -a
+       dh_shlibdeps -a
+       dh_gencontrol -a
+       dh_md5sums -a
+       dh_builddeb -a
 
 binary: binary-indep binary-arch
 .PHONY: get-orig-source build clean binary-indep binary-arch binary install