Code

Update debian/patches-repack/* for 4.0.
[pkg-enblend.git] / debian / patches-repack / 00-win32helpers.patch
index 2466925731362f435487679dd9d18fad3d11e556..3713bf7d89fb59e4364bdeb2951ecd200d50a2ca 100644 (file)
@@ -1,98 +1,23 @@
-diff a/Makefile.am b/Makefile.am
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,2 +1,2 @@
--EXTRA_DIST = VIGRA_LICENSE README_WINDOWS.txt enblend.sln enblend_msvc2003.sln enblend_msvc2008.sln
-+EXTRA_DIST = VIGRA_LICENSE README_WINDOWS.txt
- SUBDIRS = include doc src
-diff a/configure.in b/configure.in
---- a/configure.in
-+++ b/configure.in
-@@ -140,8 +140,7 @@
-                  include/vigra/Makefile
+diff -NurbBp a/configure.in b/configure.in
+--- a/configure.in     2009-12-05 08:26:45.000000000 +0100
++++ b/configure.in     2009-12-20 14:17:56.000000000 +0100
+@@ -524,7 +524,6 @@ AC_CONFIG_FILES([Makefile
                   include/vigra_ext/Makefile
                   src/Makefile
--                 src/vigra_impex/Makefile
--                 src/win32helpers/Makefile])
-+                 src/vigra_impex/Makefile])
+                  src/vigra_impex/Makefile
+-                 src/win32helpers/Makefile
+                  doc/Makefile])
  AC_OUTPUT
  
- AC_MSG_RESULT([
-diff a/src/Makefile.am b/src/Makefile.am
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,5 +1,4 @@
--EXTRA_DIST = enblend.vcproj enblend_msvc2003.vcproj enblend_msvc2008.vcproj enfuse.vcproj enfuse_msvc2003.vcproj enfuse_msvc2008.vcproj
+diff -NurbBp a/src/Makefile.am b/src/Makefile.am
+--- a/src/Makefile.am  2009-12-02 08:27:29.000000000 +0100
++++ b/src/Makefile.am  2009-12-20 14:18:42.000000000 +0100
+@@ -3,7 +3,7 @@ AM_CFLAGS = $(EXTRACFLAGS)
+ AM_CXXFLAGS = $(EXTRACXXFLAGS)
+ AM_LDFLAGS = $(EXTRALDFLAGS)
 -SUBDIRS = vigra_impex win32helpers
 +SUBDIRS = vigra_impex
- bin_PROGRAMS = enblend enfuse
- enblend_SOURCES = anneal.h assemble.h blend.h bounds.h common.h enblend.h enblend.cc fixmath.h float_cast.h gpu.cc gpu.h mask.h nearest.h numerictraits.h path.h pyramid.h
- enblend_LDFLAGS = -ffast-math
-diff a/src/enblend.cc b/src/enblend.cc
---- a/src/enblend.cc
-+++ b/src/enblend.cc
-@@ -21,11 +21,6 @@
- #include <config.h>
- #endif
--#ifdef _MSC_VER
--#include <win32helpers\win32config.h>
--#define isnan _isnan
--#endif // _MSC_VER
--
- // Defines lrint for fast fromRealPromotes
- #include "float_cast.h"
-@@ -49,14 +44,7 @@
- #include <list>
- #include <vector>
--#ifndef _WIN32
- #include <getopt.h>
--#else
--//extern "C" int getopt(int nargc, char** nargv, char* ostr);
--extern "C" {
--#include <win32helpers/getopt_long.h>
--}
--#endif
  
- extern "C" char *optarg;
- extern "C" int optind;
-diff a/src/enfuse.cc b/src/enfuse.cc
---- a/src/enfuse.cc
-+++ b/src/enfuse.cc
-@@ -21,11 +21,6 @@
- #include <config.h>
- #endif
--#ifdef _MSC_VER
--#include <win32helpers\win32config.h>
--#define isnan _isnan
--#endif // _MSC_VER
--
- // Defines lrint for fast fromRealPromotes
- #include "float_cast.h"
-@@ -49,14 +44,7 @@
- #include <list>
- #include <vector>
--#ifndef _WIN32
- #include <getopt.h>
--#else
--//extern "C" int getopt(int nargc, char** nargv, char* ostr);
--extern "C" {
--#include <win32helpers/getopt_long.h>
--}
--#endif
+ bin_PROGRAMS = enblend enfuse
  
- extern "C" char *optarg;
- extern "C" int optind;
-diff a/src/vigra_impex/Makefile.am b/src/vigra_impex/Makefile.am
---- a/src/vigra_impex/Makefile.am
-+++ b/src/vigra_impex/Makefile.am
-@@ -1,4 +1,3 @@
--EXTRA_DIST = vigra_impex.vcproj vigra_impex_msvc2003.vcproj vigra_impex_msvc2008.vcproj
- noinst_LIBRARIES = libvigra_impex.a
- libvigra_impex_a_SOURCES = auto_file.hxx bmp.cxx bmp.hxx byteorder.cxx byteorder.hxx codecmanager.cxx codecmanager.hxx error.hxx gif.cxx gif.hxx hdr.cxx hdr.hxx iccjpeg.c iccjpeg.h imageinfo.cxx jpeg.cxx jpeg.hxx png.cxx png.hxx pnm.cxx pnm.hxx rgbe.c rgbe.h sun.cxx sun.hxx tiff.cxx tiff.hxx viff.cxx viff.hxx void_vector.cxx void_vector.hxx exr.cxx exr.hxx
- #libvigra_impex_a_CXXFLAGS = -I${top_srcdir}/include -O3 -Wall -DHasPNG -DHasJPEG -DHasTIFF