Code

collection4.*: Make Apache configuration configurable using debconf.
[pkg-collection4.git] / debian / rules
index 8bbe2d23bb3940e685f3258d01e949e6409be701..64b6fb0a8847937d64ca755c78f49483118068a3 100755 (executable)
@@ -3,6 +3,8 @@
 #
 # Written by Sebastian Harl <tokkee@debian.org>
 
+include /usr/share/quilt/quilt.make
+
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
@@ -26,19 +28,20 @@ config.status: configure
                        --host=$(DEB_HOST_GNU_TYPE) \
                        --build=$(DEB_BUILD_GNU_TYPE) \
                        --prefix=/usr \
+                       --sysconfdir=/etc \
                        --mandir=\$${prefix}/share/man \
-                       CFLAGS="$(CFLAGS)"
+                       CFLAGS="$(CFLAGS)" LDFLAGS="-lm"
 
 build: build-stamp
 
-build-stamp: config.status
+build-stamp: $(QUILT_STAMPFN) config.status
        dh_testdir
        
        $(MAKE)
        
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -46,6 +49,7 @@ clean:
        [ ! -f Makefile ] || $(MAKE) distclean
        
        dh_clean
+       debconf-updatepo
 
 install: build
        dh_testdir
@@ -53,7 +57,9 @@ install: build
        dh_prep
        dh_installdirs
        
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/collection4
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+       
+       dh_install --sourcedir=debian/tmp --fail-missing
 
 binary-indep: build install
        # nothing to do here
@@ -63,6 +69,7 @@ binary-arch: build install
        dh_testroot
        dh_installchangelogs
        dh_installdocs -a -A AUTHORS README
+       dh_installdebconf -a
        dh_link -a
        dh_strip -a
        dh_compress -a