Code

collection4.*: Make Apache configuration configurable using debconf.
[pkg-collection4.git] / debian / rules
index 17e9846b3b3388167d2aedce5e464c15c09a3946..64b6fb0a8847937d64ca755c78f49483118068a3 100755 (executable)
@@ -30,7 +30,7 @@ config.status: configure
                        --prefix=/usr \
                        --sysconfdir=/etc \
                        --mandir=\$${prefix}/share/man \
-                       CFLAGS="$(CFLAGS)"
+                       CFLAGS="$(CFLAGS)" LDFLAGS="-lm"
 
 build: build-stamp
 
@@ -49,6 +49,7 @@ clean: unpatch
        [ ! -f Makefile ] || $(MAKE) distclean
        
        dh_clean
+       debconf-updatepo
 
 install: build
        dh_testdir
@@ -68,6 +69,7 @@ binary-arch: build install
        dh_testroot
        dh_installchangelogs
        dh_installdocs -a -A AUTHORS README
+       dh_installdebconf -a
        dh_link -a
        dh_strip -a
        dh_compress -a